Configuring a vPC on a Cisco Nexus 9k
vPC Configuration
On Switch 1
configure t
feature vpc
feature lacp
int mgmt 0
ip add 10.30.0.49 255.255.255.252
no shutdown
!
vpc domain 100
role priority 100
peer-keepalive destination 10.30.0.50 source 10.30.0.49 vrf management
!
int e1/47-48
description **VPC Peer-Link**
channel-group 2 mode active
no shutdown
switchport
!
interface port-channel 2
description **VPC Peer-Link**
no shutdown
switchport
switchport mode trunk
vpc peer-link
On Switch 1
configure t
feature vpc
feature lacp
int mgmt 0
ip add 10.30.0.49 255.255.255.252
no shutdown
!
vpc domain 100
role priority 100
peer-keepalive destination 10.30.0.50 source 10.30.0.49 vrf management
!
int e1/47-48
description **VPC Peer-Link**
channel-group 2 mode active
no shutdown
switchport
!
interface port-channel 2
description **VPC Peer-Link**
no shutdown
switchport
switchport mode trunk
vpc peer-link
On Switch 2
configure t
feature vpc
feature lacp
int mgmt 0
ip add 10.30.0.50 255.255.255.252
no shutdown
!
vpc domain 100
role priority 200
peer-keepalive destination 10.30.0.49 source 10.30.0.50 vrf management
!
int e1/47-48
description **VPC Peer-Link**
channel-group 2 mode active
no shutdown
switchport
!
interface port-channel 2
description **VPC Peer-Link**
no shutdown
switchport
switchport mode trunk
vpc peer-link
On Switch 2
configure t
feature vpc
feature lacp
int mgmt 0
ip add 10.30.0.50 255.255.255.252
no shutdown
!
vpc domain 100
role priority 200
peer-keepalive destination 10.30.0.49 source 10.30.0.50 vrf management
!
int e1/47-48
description **VPC Peer-Link**
channel-group 2 mode active
no shutdown
switchport
!
interface port-channel 2
description **VPC Peer-Link**
no shutdown
switchport
switchport mode trunk
vpc peer-link
Connecting a Downstream Device
Connecting a Downstream Device
On Switch 1
configure t
interface e1/1
description Link to Downstream Device
channel-group 10 mode active
no shut
!
interface port-channel 10
switchport
vpc 10
no shut
On Switch 1
configure t
interface e1/1
description Link to Downstream Device
channel-group 10 mode active
no shut
!
interface port-channel 10
switchport
vpc 10
no shut
On Switch 2
configure t
interface e1/1
description Link to Downstream Device
channel-group 10 mode active
no shut
!
interface port-channel 10
switchport
vpc 10
no shut
On Downstream device;
configure t
interface range gi1/0/47-48
description Link to Upstream Device
channel-group 10 mode active
no shut
!
interface port-channel 10
switchport
no shut